Participant

Do any of you have a problem getting into etoro trading tool? i mean the webtrader part not social book..

It so annoying.. this is what i get now trying to login:

-Please wait while loading Having problem loading the page?

-To view this page ensure that Adobe Flash Player version 10.0.0 or greater is installed.

then wait and nothing!! weird thing is some times it works some times i just cannot get in! It seems as if when you want to take your trades off is just when you cant get in! i checked the cookies, flash and that but i just cannot figure it. no luck with Firefox nor explorer. there is no help by the way on etoro site for this. looked and they don’t reply to email i just get a reply saying support email no longer in use go to help pages. useless”!”

 
Participant

I had same problems then I only have a demo account on there so not too bothered about it. Did you try getting on from a separate p/c? when I could not do the login tried from a different p/c and it worked. no explanation for that.

 
Participant

I think this just happened since there was a maintenance on etoros end. It went back a day after for me.

You must be logged in to reply to this topic.